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About this tutorial
Thank you for choosing XMPie uDirect Studio version 12.1 and Adobe InDesign CC2023 to create and 
produce your variable data print (VDP) Campaigns.

This tutorial will help you get started with uDirect Studio, by showing you how to create a simple VDP 
Campaign using a personalized image and chart from concept to production.

For the purposes of this tutorial, your client is a fictional company named StarCom - a cellular provider 
selling both phones and call plans. StarCom wants you to create a "Happy Birthday" campaign, wishing its 
customers a happy birthday and offering them free or discounted text messages sent on their birthday.

It is recommended that you allocate  little more than an hour to this tutorial.

By the end of the process, you will know how to produce the two-sided dynamic postcard shown below 
using a wide range of variable design elements.

Target audience
This tutorial is designed to provide basic information, step-by-step instructions, and sample materials for 
self-learning. Should you require more assistance, please refer to the uCreate Print e-Learning course on 
XMPie Campus: https://campus.xmpie.com/s/uCreatePrint. 

The content is designed for customers who have purchased or are evaluating XMPie uDirect or 
PersonalEffect and wish to learn how to use XMPie's uCreate Print product to create document templates 
for VDP production.

It is expected that the reader will already have a basic working knowledge of Adobe InDesign. If not, it is 
recommended to first complete some basic InDesign training, for example, courses with Adobe: 
https://helpx.adobe.com/indesign/tutorials.html or a 3rd party organization such as Linkedin.com: 
https://www.linkedin.com/learning/search?keywords=indesign

Prerequisites 
This tutorial assumes that you:

	z Are familiar with Adobe InDesign and Photoshop, 
	z have a basic understanding of Excel or text-based data, 
	z have a basic understanding of the aims of Variable Data Print (VDP), and
�	 have Adobe InDesign CC2023 installed (trial version is acceptable).

https://campus.xmpie.com/s/uCreatePrint
https://www.linkedin.com/learning/search?keywords=indesign
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Tutorial materials
If you don't already have XMPie uCreate Print installed, you can download the trial version from: 
https://www.xmpie.com/trial-software-and-tutorials/

The sample InDesign files and resource images to complete this tutorial 
are also available from the above URL, or from XMPie Campus, Tutorials 
section. (Look for the uDirect Studio Tutorial (Happy Birthday).)

When you unzip the tutorial materials, you should find these files.

Important notice about usage rights 
The materials supplied for this tutorial are intended for training use ONLY. The sample postcard contains 
images that cannot be re-used for commercial use. 

In the event you wish to use the uImage "cake" template for your own projects, we refer you to:  
www.shutterstock.com, where you can purchase the rights to legally use the images and obtain the high 
resolution version: 
Front page – Cake: ID 5431351   
Back page – Raspberries: ID 6006028

Additional resources
	z uCreate Print User Guide (Access via the help menu on the Dynamic Content panel).
	z uCreate Print Tutorial videos (Access at https://campus.xmpie.com/s/uCreatePrint) 

uDirect or uCreate Print? - Disambiguation
uDirect Studio is a package of three applications from XMPie called uCreate Print, uImage and uChart. 
This tutorial demonstrates the use of these applications.

https://www.xmpie.com/trial-software-and-tutorials/
https://campus.xmpie.com
http://www.shutterstock.com
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Module 1: 
Project briefing
The first step to creating any successful campaign is to plan out a campaign brief, covering all aspects of 
your campaign: goals, strategies, target audience, materials specification etc. When planning a variable 
data campaign, this brief should also include the business rules and requirements for variability in the 
design. 

Duration
About 15 minutes

Objectives
After completing this module, you will be able to:

	z Understand the customer requirements for the Happy Birthday campaign,
	z Examine the provided data and sample files, and
	z Plan or review the Content Object (Content Objects) needed to achieve the campaign brief.

Information
Campaign brief

As stated earlier, the general goal of our “Happy Birthday” campaign is to send StarCom’s customers 
a personalized postcard, wishing them a happy birthday, and offering them free or discounted text 
messages sent on their birthday.  (Your future projects should have much more detail, but for a tutorial, 
we are keeping things short and to the point.)

Project data

One of the most important aspects of Variable Data Print, is the data. Understanding the information you 
have and ensuring that you have the information necessary to meet the campaign goals is critical. 

For example in this Happy Birthday campaign, having the customer's date of birth (DOB) and address is 
critical. Not just that we have the fields in the data, but that there are values for each recipient and that 
the information is accurate.

StarCom has provided two CSV data files for the project. 

The main recipient information is in the StarCom_Customers.csv file. The data looks like this:
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There is also a secondary database called CostSumary.csv which contains information 
about the customer's billing and charges for their cell phone service including calls, 
text and internet. Note that each customer has multiple rows of billing data that we 
can use to display a table or the case of this tutorial, we will create a chart.

Review the project objectives and check that we have the necessary information in the database to 
achieve the required outcomes. For example:

	z Do we have date of birth (DOB) values for each recipient?
	z Do we have the first name for each recipient? (For example, not a first initial.)
	z Is there a valid address for each recipient?
	z Do we have the phone model for each recipient in order to display the corresponding graphic?
	z Is the club level provided and are the provided values consistent?

Business rules for variability in the design 

To achieve this goal, StarCom compiled a detailed list of business rules and requirements, determining 
which elements in the design should be variable.

Variability requirements are implemented using different types of Content Objects: Text, Graphic, etc. 
For example, you will implement the requirement for a personalized birthday wish using a Text Content 
Object, and the requirement to display the recipient’s phone model – using a Graphic Content Object. 

The following table specifies StarCom’s Happy Birthday campaign requirements, including the type of 
Content Object, its location on the postcard (front or back), and whether the information is provided in 
the data or whether a business rule needs to be created.

Content Objects automatically created from data source fields
Content Objects to create manually 

Content  
Object Name Type Location in Design Notes

RID Text
First Name Text Birthday wish on front; 

address block on back
Last Name Text Address block on back Convert to uppercase
Club Level Text
DOB Text Birthday wish on back Format date to month and day
Phone Model Graphic Back
Activation Text
Gender Text
Address1 Text Address block on back Format to uppercase
Address2 Text Address block on back Format to uppercase; suppress empty 

line if no value
City Text Address block on back Format to uppercase
State Text Address block on back
ZIP Text Address block on back
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Content  
Object Name Type Location in Design Notes

e-mail Text
URL First Text URL on front and back Format first name to lower case
URL Last Text URL on front and back Format last name to lower case
Cake Graphic Front Personalized cake image

Cost Summary Table Used to create pie chart 
on back

Select usage data from CostSummary.
CSV based on customer RID

Back Background Graphic Back Graphic needs to change based on 
each customer's phone model

Back Name Text with Style Birthday wish on back Color needs to change based on 
background image

Offer Text Offer text on back "50% discount!" for regular 
customers; "free of charge!" for Stellar 
customers

Stellar Visibility Back Show the Stellar logo only if 
customer is in the Stellar Club Level

Campaign materials specification

The Campaign materials specification is a complete list of all files required to create and produce your 
tutorial campaign. The following table defines the different types of materials used in a variable data 
Campaign (Data, Design, Assets etc.), and describes the specific example files used in this tutorial. 

Folder Description Tutorial sample
Data The data sources 

containing the 
recipient information.

The files in the Data folder:

	z StarCom_Customers.csv—a 1000 record CSV (Comma 
Separated Values) file. This type of file is a flat database 
table that many contact or address book programs can 
generate. Note that the first twenty records are repeated 
throughout the data source.

	z CostSummary.csv - a 4000 record CSV (Comma Separated 
Values) file. This type of file is a flat database table that 
billing software would typically generate. This table 
contains 4 records for each recipient in the StarCom_
Customers.csv.  Each record contains cost information for 
one of the bill components; incoming calls, outgoing calls, 
text messages and internet. 

To examine this data source, open it with Microsoft Excel, 
Windows Notepad or Macintosh TextEdit.  Warning: if you 
open the CSV file in Excel, do not re-save it. Excel can change 
data unexpectedly. 
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Folder Description Tutorial sample
Root folder The design documents 

to be edited with 
InDesign and uDirect 
Studio.

The files in the root folder:

	z StudioTutorialStatic_CC2023.indd —this is the InDesign 
document created by the graphic designer with static 
values that need to be made dynamic.

	z StudioTutorialCompleted_CC2023.cpkg - this is 
an exported campaign package of the above Static 
Document, after it has been transformed into a Dynamic 
Document using uDirect Studio. 

Note: The required document size is 5.6’’ x 4.25’’ with a built-in 
0.125’’ (9pt) bleed (Approximately 142 x 108mm with 3mm 
bleed.)

Resources Static graphic files that 
remain the same for all 
recipients.

The graphics in the Resources folder:

	z StellarLogo.eps—the “Platinum Club” logo
	z XMPieLogo.eps—the XMPie logo
	z cake_jane.eps —this is a temporary file and will be 

replaced by the personalized image created for each 
recipient by uImage.

Assets Variable graphic files 
that can change  per 
recipient based on 
rules.

The files in the Assets folder:

	z back1.eps — the original background image for the 
postcard’s back page

	z back2.eps — an alternative background image for the 
postcard’s back page

	z SC_001.eps through SC_006.eps—phone images: The 
StarCom_Customers.csv database contains a “Phone 
Model” column, where each field names the image file to 
be used for each recipient.

Fonts Fonts used in the 
document design.

The files in the Fonts folder:

	z Expressway Free (True Type) – used in the InDesign 
document

	z Coolvetica (True Type) – used in the InDesign document
	z Chiller (True Type) – used in the Photoshop template

uImage 
Template

The document package 
of the uImage template

Files in the uImageTemplate folder:

	z coverDynamic.dpkg – this is a package file created by 
uImage. It contains a Photoshop template, Photoshop 
action and font used to create the cake image for the 
background image of the front page. For more information 
about creating uImage document packages, please refer to 
XMPie Campus.  
Note that after completing the tutorial, the package will be 
unzipped and you will see a folder containing the template, 
action, font and output images created by uImage.

https://campus.xmpie.com


XMPie Tutorial	 XMPie uDirect Tutorial - Happy Birthday Campaign r6.3 (software v12.1)	 11

Assets

It is also worth double-checking that you have all the necessary assets. In this tutorial, we will display an 
image of the customer's phone model. In addition to checking the database, we should also check that 
we have all the necessary phone model images. This involves checking the data to compile a list of each 
phone model, and checking the assets folder includes an image with this name.
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Module 2: 
Creating a dynamic document
Now that we understand the basic aims of the project, the available resource materials and have planned 
out the Content Objects required, we can start work to create the dynamic document.

Duration
About 45 minutes.

Objectives
After completing this module, you will be able to:

	z Link a static InDesign document to a data source,
	z Place database values into the document design,
	z Create Text, Text with Style, Graphic Table and Visibility Content Objects,
	z Create simple rules or logic to change text (or graphics) in the document based on a data source value, 
	z Manage dynamic text and graphic copy fitting.

Preparation
	z If Adobe InDesign and Photoshop are not already installed, use the Adobe Creative Cloud application 

to install InDesign and Photoshop CC2023. 
	z If uCreate Print is not already installed, browse to https://www.xmpie.com/trial-software-and-tutorials/
	z If you purchased uDirect, after installing you should activate your license:  

Open InDesign, select Dynamic Content -> Help -> Activate license... 
(If you do not have a license, you can still create the template and see how uCreate Print works, but 
you will not be able to create the final print output.)

	z Download and unzip the tutorials files.

https://www.xmpie.com/trial-software-and-tutorials/
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Getting started
Open the static tutorial document

Start Adobe InDesign, and open the StudioTutorialStatic_CC2023.indd file. 

Update fonts and links if prompted

If InDesign does not automatically find the document fonts, you may encounter this warning dialog:

 
If InDesign prompts you to find missing fonts, you 
can either install the fonts provided in tutorial 
Document Fonts folder, or replace the missing 
fonts with fonts of your choice.

In some cases, InDesign may also prompt you to find missing links:

 
If InDesign prompts you to find missing links, 
click: OK, then open the Links panel (Ctrl-Shift-D)

 
Right-click on each missing image (indicted by the red 
question mark) and select Relink. Browse to locate the 
relevant image in either the Assets or Resources folders 
provided with the tutorial.

Save the file under a different name.

In order to keep the original static document (so you can repeat the tutorial again later) you may want to 
select File -> Save As…, and enter a new name for your working document. 

Set InDesign display properties

To preview the images properly on screen, select View -> Display Performance and select High Quality 
Display.



14	 XMPie uDirect Tutorial - Happy Birthday Campaign r6.3 (software v12.1)	 XMPie Tutorial

The Dynamic Content menu
If uCreate Print has been installed, InDesign will display a new menu group called Dynamic Content. This 
menu provides the tools for you to change the static InDesign document into a dynamic template.

 

Link to the recipient data source

The first step to creating a dynamic template is to link the InDesign document with a datasource.

From the Dynamic Content menu, select 
Set input data...

 

Select Data Source File and click OK.

 
Click Browse, and select the StarCom_Customers.
csv file in the tutorial Data folder. 

Additional information and notes

The Set input data option will only be available if there is an open InDesign document. If the 
menu option is grayed out, open the StudioTutorialStatic_CC2023.indd document or your 
working InDesign file. 

Additional information and notes

There are also other types of data including Counters and 
Plan files which you can explore in future, but are not 
covered in this tutorial.
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The field Separator in the tutorial data source is a 
Comma. Click OK.

You will see confirmation that the data source has been linked. 

Click OK.

The Dynamic Content panel
Open the Dynamic Content panel

To place Content Objects into the document design, open the Dynamic Content panel.

From the Dynamic Content menu, select Show Window -> Dynamic Content.

 

Additional information and notes

The Dynamic Content panel can also be toggled on/off with the Window -> XMPie -> 
Dynamic Content menu.
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The Dynamic Content panel now shows all the 
field names from the data source. 

These are Content Objects which can be placed 
into the document to display dynamic content.

Set the Assets folder

You need to set the assets folder to specify the location of any graphic or text file assets. For example, the 
phone model images in this tutorial.

 
From the Dynamic Content menu, select Assets... 

 
Browse to the Tutorial folder, select the folder 
named Assets, and click Select Folder.

 
 

Displaying data values in the panel

Sometimes, it is helpful to see the data values in the Dynamic Content panel. 

From the Dynamic Content menu, select Preferences...
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Check the box next to Show Data Column in 
Dynamic Content Panel.

Click OK.

 
The data values of the first record are now visible next to the Content 
Object names.

Modify the front (page 1)
Place a Text Content Object into the design

Move to the first page of the document if it is not already displayed.

 
In the InDesign Tools panel, select the Type tool.

Highlight or select the text Jane (make sure you 
select the entire name).

In the Dynamic Content panel, double-click the 
First Name Content Object.

 
 

Jane is the first customer (record 1 of 1000) in the StarCom_Customers.csv data source that your design is 
currently linked to, so at first it may look like nothing has changed. 

Additional information and notes

At the bottom of the Dynamic Content panel, you can see 
the name of the data source that you are connected to, 
and there is a text box and up/down arrow icons showing 
the current record number, and allowing you to move to 
preview different records from the data source.
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Check the design for different recipients/records

 
In the lower part of the Dynamic Content panel, 
click the up arrow to go to the recipient #2 (Jerry). 

Note that the text now shows Congratulations 
Jerry.

Notice that uCreate Print is highlighting the 
dynamic objects in the design. 

 
If the highlighting distracts you from the design, 
from the Dynamic Content menu, you can turn off 
Highlight All Content Placeholders.

Duplicating Content Objects

The next 2 steps demonstrate how to duplicate a Content Object in order to retain the programming 
logic of the original Content Object and at the same time make changes to the formatting of the new 
one. 

In this example, we want to modify the formatting of the First Name and Last Name Content Objects so 
the personalized URL will be all lower case, regardless of character case in the database.

Additional information and notes

Highlighting of dynamic objects will not be shown if you are using InDesign's Preview 
mode. From the InDesign menu, select View -> Screen Mode and select Normal to show the 
highlighting, together with the Highlight Content Placeholders setting.



XMPie Tutorial	 XMPie uDirect Tutorial - Happy Birthday Campaign r6.3 (software v12.1)	 19

 
Right-click the First Name Content Object and choose Duplicate 
from the context menu.

A First Name copy Content Object is added at the bottom of the 
Content Objects list.

 
Right-click the new First Name copy Content Object and choose 
Rename... from the context menu.

 
In the New Name text box, type URL First and click 
Rename.

The Content Object list now shows the updated name.

Edit a Content Object Rule to convert text to lower case

 
Right-click the URL First Content Object, and choose Edit Rule… 
from the context menu.
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From the second drop-down list, scroll 
up and choose lowercase.

 
 

 
The value [T] First Name moves over 
into the parameters list. (Parameters 
are the pieces of information required 
to perform a function. Parameters are 
located within the parentheses.)

Note at the bottom of the dialog is a 
preview area that shows the result of 
the expression.

Click OK to close the Rule Editor. 

Repeat the above steps to duplicate the Last Name Content Object, rename it to URL Last and edit the 
URL Last Content Object adding the function to lowercase the last name.

Add more Text Content Objects to the design

 
In the InDesign Tools panel, select the Type tool.

Select the first name (jane) in the URL line at the 
bottom of the card and then double click the URL 
First Content Object.

Repeat the process to replace the static last name in the URL with the URL Last Content Object.

Additional information and notes

In this example, the personalized URL is managed by StarCom manually. When using 
XMPie PersonalEffect TransMedia to create personalized websites, the URL is managed 
automatically. For more information, refer to the Cross Media training guides on XMPie 
Campus.
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Create a uImage Graphic Content Object or Content Object

In this task you will create a new Graphic Content Object, and use uImage settings in the Rule Editor to 
select and configure a uImage Photoshop package.

 
From the Dynamic Content panel 
menu, select New Content 
Object...

In the Name field, type Cake.

From Type drop-down list, select Graphic.

Check the box to Edit Rule. 

Click OK.

 
Select uImagePhoto from the 
second drop-down in the 
expression line.

Click the Package button.

 
Click Browse next to the Template Package field, 
navigate to your tutorial folder and from the 
uImageTemplate folder, select coverDynamic.dpkg, 
and click Open.

All other uImage settings can be left as default for 
this tutorial. 

Click OK to close the uImage settings.

Additional information and notes

You can also right-click on any Content Object to select New Content Object... from the 
context menu.
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Click OK to close the Rule Editor.

After closing the Rule Editor, you may notice that Photoshop will start up and automatically create the 
personalized image for the current record being previewed by uCreate Print.

Be patient and wait for a moment while the image is created.

If Photoshop launched in front of InDesign, swap back to InDesign.

 
In the InDesign Tools panel, choose 
the Selection tool.

Click to select the static 
background image, and in the 
Dynamic Content panel, double-
click the Cake Content Object.

Additional information and notes

For more information on the other uImage settings, please refer to the uImage Help. From 
the Dynamic Content menu, select Help -> uImage Help.
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If you are still viewing record #1 
(Jane) it may appear that nothing 
has changed because the original 
static file also had Jane's name.

Click the record selector up arrow 
to move onto record #2 (Jerry) 
to confirm the next personalized 
image is created correctly.

Additional information and notes

You will notice that as you scroll to new records, there will be a slight delay as Photoshop 
creates the next image required to preview in InDesign. This occurs only once for each 
first name. Once the image is created for a recipient, Photoshop is not used again for other 
records with the same name.

Additional information and notes

If you do not have a 
license for uImage, you 
will notice a "watermark" 
appears over the 
personalized images. 

This is normal, and can be 
removed by activating a 
uImage license. (Dynamic 
Content menu -> Help 
-> Add License.) After 
adding a license you 
should restart both 
Photoshop and InDesign.
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Modify the back (page 2)
Move to the second page of the document. If the graphics look pixelated, switch InDesign to high quality 
display: View -> Display Performance -> High Quality Display.

Place more Text Content Objects into the design

In the InDesign Tools panel, select the Type tool.  

In the URL line, select the text jane and double-click the URL First Content Object.

Repeat the process to replace jones with the URL Last Content Object.

Move to the address block. Repeat the process of selecting the text and double-clicking the relevant 
Content Object to place First Name, Last Name, Address1, Address2, City, State and Zip Content Objects 
into the design.

Additional information and notes

 The name of the Graphic Content object will also appear if 
Highlight All Content Placeholders is selected in the 
Dynamic Content menu.

Additional information and notes

Note that the design does not include a second address line. You will need to position the 
cursor, create a new line and double-click to add the Address2 Content Object.

Additional information and notes

 
Note that some database records do not 
have any information in the Address2 field, 
so when you double-click to place 
Address2 it may appear that nothing has 
happened. 

 
Move onto record #5 (Sandra) who has a 
second address line to confirm the Content 
Object was added correctly.
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Suppress Trailing Spaces on Empty Content

Where customers do not have a second address line, it looks a bit odd having a gap in the middle of the 
address block. So, we want to close this space.

 
In the InDesign Tools panel, choose 
the Selection tool.

Click to select the text frame that 
contains the address block. Right-
click on the selected text frame.

From the context menu, select Dynamic Content -> Suppress Trailing Spaces on Empty Content.

Confirm the change by scrolling between records #4 (Jimmy) and #5 (Sandra). You should see the City, 
State and Zip text move upwards when there is no Address2 line.

Edit rules to convert text to upper case

One of the requirements from our customer, StarCom, was to format the Last Name, Address and City 
fields in upper case. Since these Content Objects are not used anywhere else in the design, we don't need 
to duplicate them, we can simply edit the rule to add the UPPERCASE function to format the text.

In the Dynamic Content panel, right-click on the Last Name Content Object and select Edit... from the 
context menu.

 
From the second drop-down list, 
scroll up and choose UPPERCASE.

In the preview area at the bottom 
of the dialog, confirm your 
expression is working correctly.

Click OK.

The Last Name in the address 
block should also now appear in 
uppercase.

Repeat the process to uppercase the Address1, Address2 and City Content Objects.

Additional information and notes

In some cases, for example business cards, you may want to top lines to move downwards. 
You can easily do this by using the standard InDesign Text Frame Options dialog and 
changing the Vertical Justification setting.
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Create a Table Content Object

Now, we want to create a pie-chart to display the monthly cost summary of services for each recipient. 
The first step is to create a Table Content Object using the CostSummary.csv file as your data source.

From the Dynamic Content panel menu, select New Content Object… (Or right-click any Content Object 
in the Dynamic Content panel and select New Content Object... from the context menu.)

Enter a Name for the new Content Object: Cost 
Summary.

From the Type drop-down list, select Table.

Click OK.

 
Click Browse. Navigate to your 
Tutorial folder and in the Data 
folder, select the CostSummary.csv 
file, and click Open.

The Separator is Comma.

From the Table Field drop-down 
list, select CustID.

From the Equals Recipient Field 
drop-down list, select RID.

Click OK to save your new Table Content Object.

Additional information and notes

The above settings tells uCreate Print to select the rows from the CostSummary.csv file where 
the CustID value is the same as the RID value from the main recipient data source (StarCom_
Customers.csv) for the currently displayed recipient.

Additional information and notes

A Table Content Object can be used in two ways in uCreate Print. If you select a text frame 
and double-click, an InDesign table will be created. If you select a graphic frame and double-
click, a chart will be created. For this tutorial, we want the graphic frame for a chart.
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Create a Dynamic Chart

The next step is to create a dynamic chart by tagging a graphic frame with a Table Content Object.

In the InDesign Tools panel, choose the Selection tool.

 
Click to select the static placeholder pie chart 
graphic frame.

In the Dynamic Content panel, double-click the 
Cost Summary Table Content Object.

The static placeholder image disappears and a plain pie chart appears 
indicating that the frame has been associated with the selected Table 
Content Object.

Define uChart Properties

Now we can specify how the Table Content Object data should be presented in the chart.

First, it is easiest if you turn off Highlight All Content Placeholders in the Dynamic Content menu so you 
can more clearly see the pie chart.

Additional information and notes

 
If you do not see a pie chart and the 
graphic frame appears to be empty, use 
the selection tool to right-click the 
graphic frame and select Fitting -> Fit 
Content Proportionally. 

Repeat and select Fitting -> Center Content. 

Additional information and notes

 
If you do not have a license for uChart, you will notice a 
"watermark" appears over the chart. This is normal, and 
can be removed by activating a uChart license. (Dynamic 
Content menu -> Help -> Activate License). After adding 
a license you should restart InDesign.
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Right-click on the graphic frame, and select uChart Properties... from the Dynamic Content group menu.

 
Check the Preview box and position 
the panel so you can see the graphics 
frame and see how the settings change 
the chart design.

Set Type to Pie Chart.

Set Slice Data to Cost.

Check the box next to the following 
CMYK colors: 
C=100 M=90 Y=10 K=0 
C=29 M=97 Y=100 K=37 
C=34 M=3 Y=90 K=0 
C=4 M=64 Y=99 K=0

Set the Font as Trebuchet MS, size 10pt. (Use another font if this is not available on your computer.)

Set Legend to Circular. And, select to display the value of the Purpose field. 

Select the 3D and Separate Slices check boxes.
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When complete, click OK to close the uChart Properties dialog.

The chart is like any graphic in InDesign, you can now scale and position the graphic in the frame.

 
In the InDesign Tools panel, select the 
Direct Selection tool.

Click to select the chart in the graphic 
frame.

Set both horizontal and vertical scale 
to 45%.

Make sure the reference point is in the 
top left-hand corner, and enter the 
following positional values:

X+: -0.32 in 
Y+: 0.2 in 
W:  2.7 in 
H:  0.9 in

When done, test some other recipients 
to see the preview of the chart change.

Creating Graphic Content Objects

Our customer wants to display a photo of the customer's phone model on the postcard. All the database 
values are created as Text Content Objects. Since the phone model is not used as text somewhere else in 
the document, we don't need to create a new Content Object, we can simply change the Type to Graphic.

Additional information and notes

uChart has many more settings than can be displayed in the panel, so XMPie provides the 
Chart Options text box at the bottom of the panel for you to enter more enhanced options. 
For the full list of available settings, refer to the uCreate Print menu -> Help -> uCreate Print 
Help. Select your version/language and from the contents, select Working with uChart -> 
Using Enhanced Settings.

For this Tutorial, you could enter the following settings as an example:

/3DViewAngle 35 
/LabelColor [ 29 97 100 37 ] 
/SliceCutaway 0.2

When typing in the settings, click Apply to see the updated settings applied in the chart.

3DViewAngle changes the tilt angle. Try changing the value and click apply to see the effect.

LabelColor changes the color of the property text in CMYK  percentages.

SliceCutaway changes the space between the slices with decimal values between 0.0 and 0.5.
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In the Dynamic Content panel, right-click on the 
Phone Model Content Object. From the context 
menu, select Type -> Graphic.

Tag a static graphic with a Graphic Content Object

In the InDesign Tools panel, choose the Selection 
tool.

Click to select the static phone graphic frame.

Double-click the Phone Model Content Object.

Scroll through the records to see the phone 
image change for different recipients.

The phone image that is displayed is controlled by the database. There are six different phone models 
listed in the data SC_001 through to SC_006. The Assets folder contains six EPS images with the same 
names.

Additional information and notes

Content Objects have several possible types, which indicate the type of object they can 
change in the InDesign document. For example: Text, Graphic, Style, Visibility, etc. 

By default, all data source fields are created as a Text Content Objects when you link to the 
data file, and their type can be easily changed as needed. 

Additional information and notes

 
If you see a positional image instead of the phone model images, then 
you must have missed the step to set the Assets Folder.

From the Dynamic Content menu, select Assets... and browse to the 
Assets folder provided in the tutorial files.
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Handling image fitting dynamically

In some cases, you may have different sized asset images and need to control the way each asset is 
handled dynamically. If you move to record #11 (Gilian) you will see that the phone image does not fit in 
the frame.

 
In the InDesign Tools panel, choose the Selection 
tool.

Click to select the phone model's graphic frame.

Right-click and from the Dynamic Content 
group, select Dynamic Graphic Properties... 

 
As you can see, there are several options for you to use. The most 
appropriate setting for our use is Fit Proportionally & Centered. 

Click OK.

Using logic to select a graphic

The previous example shows how the database can contain the name of a graphic to use. But in some 
cases, you may need to use logic to control which image to display. For this example, we have two 
background images in the assets folder: back1 and back2. 

If you move to record #2 (Jerry) you will notice that his phone model (SC_002) is a light gray color that is 
not as easy to see on the blue background, so we will change the background image if the Phone Model 
= "SC_002".

Additional information and notes

Those with a keen eye will notice that the data source contains only a model number, and yet 
the asset images are named by the model number and a file extension. uCreate Print uses an 
asset resolution algorithm to select appropriate file types, so it is not necessary to specify the 
file extension.
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From the Dynamic Content panel menu, select New Content Object… 

Enter a Name for the new Content Object: Back 
background.

From the Type drop-down list, select Graphic.

Check the box to Edit Rule.

Click OK.

 
Change the first drop-down from 
Graphic = to If.

Change the second drop-down to 
[T] Phone Model.

Change the third drop-down from 
<> to = and enter the text SC_002 
in the text box.

On the second row of the expression, after Then Graphic =, change the drop-down to String and enter 
the text back2 into the text box.

On the third row of the expression, enter the text back1 into the text box.

When the settings look as they do above, click OK to save the expression.

 
Use the Selection tool to select the 
background graphic frame. 

Double-click the new Back 
background Graphic Content 
Object in the Dynamic Content 
panel to place it into the document 
design.

Additional information and notes

Note that string comparisons in uCreate Print are case sensitive. You need to enter SC_002 in 
the text box using upper case letters: "SC".



XMPie Tutorial	 XMPie uDirect Tutorial - Happy Birthday Campaign r6.3 (software v12.1)	 33

 
Move onto record #2 (Jerry).

You should see the background 
image change so that the light 
gray phone model graphic is easier 
to see.

Check other records to see the 
blue background returns for other 
phone models.

Changing Text and InDesign Styles dynamically

As you can see in the design, the alternate, dark background (back2) complements the light gray phone 
model. However, in your future campaigns you may find that changing a background image makes the 
overlaying font difficult to read. In this tutorial we will change the color of the recipient’s name, which is 
currently formatted in green in the top left corner of the back page.  

 
The InDesign file already has two Character Styles defined - Title1 (green - to use 
with the original blue background) and Title2 (orange - to use with the alternate 
dark background).

From the Dynamic Content panel menu, select New Content Object… 

Enter a Name for the new Content Object: Back 
name.

From the Type drop-down list, select Text with Style.

Check the box to Edit Rule.

Click OK.
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Change the first drop-down from 
Graphic = to If.

Change the second drop-down to 
[T] Phone Model.

Change the third drop-down from 
<> to = and enter the text SC_002 
in the text box.

On the second row of the expression, after Then Value =, change the drop-down to [T] First Name and 
select to apply the Title2 style.

After Else Value =, change the drop-down to [T] First Name and select to apply the Title1 style.

When the Content Object definition or rule appears as shown above, click OK to save your changes.

Use the InDesign Type tool to select the static text Jane and double-click the Back name Content Object.

Test the design by browsing through different records. For example, record #1 (Jane) should have the 
blue background image and the green text; record #2 (Jerry) should have the dark background image 
and his name should appear in orange text. 

Handling text copy fitting dynamically

The text frame where we just placed the Back name Content Object is fairly small. It is possible that a long 
name in the database might not fit in the provided space. XMPie provides an option to find the longest 
value (by character count) in any Content Object.

 
In the Dynamic Content panel, right-click on the 
Back name Content Object and select Go to 
Longest from the context menu.

 
uCreate print will move to the longest record 
(Jennifer), and you can see that this name will 
not fit in the available space.
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Of course, we could make the box larger, but in future we could link to a different data source with even 
longer names, so we should take care of fitting the text dynamically.

In the InDesign Tools panel, choose the Selection tool.

Click to select the text frame.

 
Right-click on the selected text 
frame, and from the context menu, 
select Dynamic Content  -> Copy 
Fit...

 
Check Copy Fit on and then select Overflow 
from the drop-down list.

Check the text size box and set the minimum 
size to 90% with a 2% step.

This setting will shrink the text size in 2% 
increments (98%, 96% etc.) until it fits the text 
box, and will not shrink below 90% of its original 
size. 

Click OK.

You should find that Jennifer now fits within the text frame, and if you preview other records, the text will 
revert to the pre-set size. Overflow copy fitting will only change the font size if it the text overflows the 
text frame.

Formatting a date

This step will format the date of birth (DOB) to appear as the month name and number to use in the 
birthday wish text.

In the InDesign Tools panel, select the Type tool.

Select the static text March 4 in the text next to the phone model image, and double-click the DOB 
Content Object.

Additional information and notes

The Minimum change value prevents uCreate Print from making the text so small that it 
becomes unreadable. In the event that the minumum set is not enough for the text to fit the 
frame, you will see the overflow on screen, and during output print production, uCreate Print 
will display a warning about the overset text.

The Step value gives great control over how to increment through text size, scale and/or 
leading. The smaller the value, the closer the text would fit the frame, but the longer it would 
take to process your print output since uCreate Print would have to test more times before 
finding a text size that fits the frame.
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Note that the date appears in the same way that it is displayed in the data source - which is not very user 
friendly.

In the Dynamic Content panel, right-click on the DOB Content Object and from the context menu, select 
Edit...

 
From the second drop-down, 
select FormatDate.

From the third drop-down, select 
[T] DOB.

In the Text box, enter MMMM d.

This will format the date as the full 
month name and the date.

For detailed information on the 
FormatDate function, refer to the 
uCreate Print User Guide.

Click OK to save your change. 

Confirm the date is now formatted correctly by browsing through some different records.

Using logic or rules to create a promotional text message

Our customer, StarCom wants to provide a birthday offer to their customers, based on their Club Level.

Customers in the Stellar club will be offered free text messaging on their birthday, while other customers 
will receive 50% discounted text messaging on their birthday.

In the Dynamic Content panel right-click any Content Object and select New Content Object… from the 
context menu.

Enter a Name for the new Content Object: Offer.

From the Type drop-down list, select Text.

Check the box to Edit Rule.

Click OK.

 
Change the first drop-down from 
Value = to If.

Change the second drop-down to 
[T] Club Level.

Change the third drop-down to =.

Change the fourth drop-down to 
String and enter the text: Stellar.
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On the second line of the expression, after Then value = change the first drop-down to String and enter 
the text: free of charge!

On the third line of the expression, enter the text: at 50% discount!

When the rule appears as shown above, click OK to save your changes.

 
In the InDesign Tools panel, select the Type tool 

Select the static text free of charge! in the text 
next to the phone model image, and double-
click the Offer Content Object.

Test the design by browsing through different records. For example, records #1 and #2 (Jane and Jerry) 
who are in the Stellar club, should have the free offer; while record #3 (Jennifer) should have the 50% 
discount offer.

Create and Use a Visibility Content Object

Visibility Content Objects are used to turn layers or page spreads on or off, depending on a value from the 
data source. 

 
For this tutorial, there is a separate InDesign layer 
which contains only the Stellar club logo.

We need to turn the layer on, only if the recipient 
is a member of the Stellar club.

Additional information and notes

Visibility is the only type of Content Object whose condition can be set to a single line, “Is 
Visible if”. All other Content Object types can have both “If”, and a one-line expression “Then 
value” and “Else value” using the Value = condition. In this step, we will learn to use the 
shortened version of the condition.
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Right-click anywhere in the Dynamic Content panel and select New Content Object… from the context 
menu.

Enter a Name for the new Content Object: Stellar.

From the Type drop-down list, select Visibility.

Check the box to Edit Rule.

Click OK.

 
Change the second drop-down to 
[T] Club Level.

Change the third drop-down to =.

In the text box, type Stellar.

When the rule appears as shown 
left, click OK to save your changes.

 
In InDesign’s Layers panel, select and right-click on 
the Stellar layer.

From the Dynamic Content menu group, select 
Layer Visibility...

From the drop-down, select the name of your 
Visibility Content Object, and click OK.

The Stellar layer is now tagged with the Stellar 
Visibility Content Object.

Test the design by browsing through different records. For example, records #1 and #2 (Jane and Jerry) 
who are in the Stellar club, should have the logo visible; while record #3 (Jennifer) should not see the 
logo. 

If you have the Layers panel open while you move through the different records,  you will see the layer 
visibility turned on and off automatically by uCreate Print.

Save the document

Congratulations! You have now completed the template setup. Save your work.
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Module 3: 
Printing a dynamic document
Now that we have completed the template setup and everything looks good on screen, we need to 
create the print output file. Note that this module will only be possible if you have a uCreate Print license. 
The trial version (without a license) will not permit print production. If you have not yet purchased 
uDirect and need to test print output, please contact your XMPie Sales Manager - it is possible to get a 30-
day evaluation license that will permit printing for a limited time.

Duration
About 10 minutes.

Objectives
After completing this module, you will be able to:

	z Locate and use the Generate VDP Output print dialog.

Procedure
For the purposes of this exercise, we will print the “Happy Birthday” postcards in a PDF format, for the first 
twenty recipients in the data source. For a full list of the available VDP print options, please refer to the 
uCreate Print User Guide.

From the Dynamic Content menu, select the Generate VDP Output option.

If you have unsaved changes, you will be prompted to save the InDesign document. 

 
From the Format drop-down list, choose 
Adobe(r) PDF.

Next to Records check the option to use the to 
and from text boxes.

Set the to box to 20, to print only records 1-20 
from our data source.

Use the (default) Destination setting.
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Click OK to create your output PDF.

The print progress window is displayed, allowing you to monitor the progress of the output files’ 
production.

When production completes, you will be returned to InDesign.

Open the Tutorial folder.

 
The default output location will create an output folder next 
to your InDesign document.

Inside the output folder, each time you dynamic print using 
the default output location, a new sub-folder is created with 
the current date and time. Inside that folder will be your 
output file.

Open the PDF and check your work. One PDF file should be created containing 40 pages - 2 per recipient/
record.

Congratulations!  You have now produced the “Happy Birthday” VDP postcard  and have successfully 
completed the uCreate Print tutorial.

Additional information and notes

The Format setting defines the Variable Information (VI) output format in which the 
document will be printed. uCreate Print provides output formats including PDF, PDF/VT-1, 
VPS, PPML, VIPP, PPML/VDX and PostScript. 

Additional information and notes

The (default) output destination will create a folder named output, next to the InDesign 
document. A sub-folder named using the current date and time will be created in the Output 
folder and will contain the output file. 

To set a different destination, click Browse and select to the desired folder. 

If you choose a different location, each time you print, you will be warned that any existing 
output file in that folder will be over written. This warning does not occur with the default 
setting becasue a new date/time folder is created each time preventing the possible loss of 
previous output files.
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Appendix A:  
Viewing the Completed Tutorial
OK, so you don't have a spare 40 minutes or so to run through the tutorial, but you want to look at the 
completed document? 

XMPie provides a "package" mechanism to allow import/export of all the resources necessary to transport 
a completed VDP document between different computers.

Follow these steps to import the completed campaign package.

Preparation
	z If Adobe InDesign and Photoshop are not already installed, use the Adobe Creative Cloud tool to 

install InDesign and Photoshop CC2023. 
	z If uCreate Print is not already installed, browse to https://www.xmpie.com/trial-software-and-tutorials/ 

to download and then install uDirect.
	z If you have purchased uDirect, add your license:  

Dynamic Content -> Help -> Add license... 
(If you do not have a license, you can still create the template and see how uCreate Print works, but 
you will not be able to create the final print output.)

	z Download and unzip the tutorial files.

Importing a Campaign Package
Open Adobe InDesign.

From the Dynamic Content menu 
select Import package...

Browse to the tutorial folder, and select the StudioTutorialCompleted_CC2023.cpkg file.

 
By default, the import will extract the files to the 
same folder that the contains the package file. 

You can click Browse if you want to change the 
location, or simply click Import for the default 
location.

The package file will be unzipped and the InDesign file will be opened.
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At the bottom of the Dynamic Content panel, 
select to preview data from the data source.

Adobe Photoshop should launch to create the first personalized Cake image.

Please be patient for a moment while the Photoshop file is opened and the image created.

In a few moments, swap back to InDesign. 

You are now viewing the completed document.
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Appendix B: 
uCreate Print quick reference
Quick Reference to the Dynamic Content panel
The following section is not a procedure; instead it provides useful information on the Dynamic Content 
panel, which will make it easier for you to understand and perform this tutorial.

The data source that your document is linked to is a database table. The table’s columns contain different 
types of recipient data: RID, First Name, Last Name, Club Level etc… 

Once you link to a data source table, uCreate Print automatically creates a Content Object for each of the 
table’s column headers. 

When you start editing your design, you will be using simple point-and-click operations to tag different 
design objects with the relevant type of Content Object. (For example, the First Name Text Content 
Object or the Phone Model Graphic Content Object.) The tagged InDesign object becomes a dynamic 
object: a design object that derives its content and/or appearance from the Content Object’s value. 

The populated Dynamic Content panel shows the following details and options:

	z Show Content Objects, Variables or Input Fields—While Content Objects are available to place into 
the document design, variables are used behind the scenes. Variables use the same kind of business 
rules or logic that we used for Content Objects in this tutorial. Variables are useful to calculate a value 
once – you can then use that variable in several Content Objects instead of having to calculate the 
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value each time. Input fields represent the expected data source structure. For example, if you expect 
to get another datasource from your customer that has additional fields/columns, you can add Input 
fields for these new data columns and work with them in uCreate Print before getting the new data 
file. Later you can link to the new data and map the input fields to the fields in the datasource.

	z Filter Content Object types — Use the drop-down list to show All Types of Content Objects, or to 
filter the list to show a specific type (For example, Text, Graphic, Visibility, etc.).

	z Content Object list — lists the names and types of the Content Objects included in the document you 
currently have open in InDesign. The name and value of Content Objects can be directly read from the 
data source you are currently linked to, or have been created and edited to show other values based 
on Content Object rules or expressions.

	z Proofing options — uCreate Print offers you a number of ways to check what your dynamic document 
will look like when actual values are used in place of the dynamic objects. These actual values can 
come from various types of content sources, including your data source, a proof set file or content 
samples.

	z Browse to data source — Allows you to link to a different data source than the one listed that the 
document is currently connected to. In order to keep all the rules and logic, the field names and data 
types of the new data source should be the same as the existing data source. You will be prompted to 
remap fields in the new data source if they do not match.

	z Filter Content Object Group — When using a Plan file instead of linking to a data source, it is possible 
to group Content Objects into folders. This option allows you to filter the list to different groups.

	z Content Object data — if Show Data Column is enabled in the Dynamic Content -> Preferences 
menu, the Content Object values for the current recipient will also display in the panel.

	z Record selector — used to proof your dynamic document: browse through the records of your 
content source (the linked proof set, a content sample or the linked data source), and see how the 
dynamic objects’ content changes when you scroll from recipient to recipient. 

	z Dynamic Visibility — Opens the dynamic visibility dialog, so you can assign a Visibility Content Object 
to the active spread or active layer (Note that the icon is the color of the active layer). When dynamic 
visibility is assigned, an eye symbol is added to the respective icon.

	z Resize panel — to see the complete list of Content Objects, resize the panel by dragging its bottom 
right corner. Alternatively, use the horizontal scroll bar to scroll down the list.

Quick Reference to the Content Object rule editor
This section will help you get familiarized with Content Object rule editor. 

Content Objects can be defined based on a number of attributes; their name, their type, and by their 
business rule (rule) which is an expression that is part of the campaign logic, and determines how to 
calculate the Content Object’s value for each recipient. 

When you connect your design to a data source, uCreate Print automatically creates an Content Object 
for each column header in that data source. You may wish to edit these Content Objects or create new 
ones, to use to tag your design with dynamic formatting, conditional rules or math operations. 

Content Objects are both edited and created using the Content Object rule editor. 

The rule editor is a simple graphic user interface, consisting of basic drop-down lists and text boxes. It is 
specifically designed to allow non-technical users to easily define or modify Content Object rules. 
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Launching the Content Object rule editor

You can launch the rule editor in one of the following ways:

	z To add a new Content Object — in the Dynamic Content menu, select New Content Object…
	z To add a new Content Object — in the Dynamic Content panel, right-click any Content Object, and 

select New Content Object… from the context menu.
	z To edit an existing Content Object — in the Dynamic Content panel, right-click the Content Object 

you wish to edit, and then select Edit… from the context menu. 

The following description applies to both the “New Content Object” and the “Edit Content Object” 
windows of the rule editor.

Using the Content Object rule editor’s building blocks

Below is an sample rule editor window, used to edit a Text Content Object (First Name). The drop-down 
lists have been expanded to reveal the available options.

The rule editor options vary, depending on the type of Content Object you are currently editing or 
defining (Text, Graphic etc.).

The first drop-down list determines whether this rule sets a value or a condition.

The second drop-down list contains building blocks for defining the Content Object’s value or condition: 
literal values (string or number), functions, and an alphabetical list of the data source columns. 

The third drop-down list includes operations, such as “+”, “-“, etc. When you define a condition (by setting 
the first drop-down list to “If”), the operations list is enhanced with comparison operators, such as “AND”, 
“OR” etc.
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Value rules

To define a rule as a value, set the first drop-down list to Value= for Text Content Objects, Graphic= for 
Graphic Content Objects, etc. 

Value expressions are used in the following cases:

	z The Content Object is a data source column header: 
An Content Object created for a data source column header is fed with the value of the appropriate 
data source field, and this value changes dynamically per-recipient. For example, the First Name 
Content Object receives the value of each recipient’s First Name field: 

	z The Content Object has a literal value (a number or a string of text):  
You can set an Content Object object to use a fixed value, which will be common to all recipients. For 
example, to set the value of a Company Logo Graphic Content Object, specify the image’s filename. 
For example, CompanyLogo: 

Condition rules

Condition Rules allow you to determine an Content Object’s value using “If-Then-Else” statements. In this 
case, we will use a condition rule to determine the value of the Offer Content Object, depending on the 
value of the Club Level data source field: 

	z If the value of Club Level is Stellar, then the value of the Offer is “free of charge!”
	z Otherwise, the value of the Offer is “50% discount!”.

To define a rule as a condition, set the first drop-down list to If. 
A basic condition consists of three lines: 

	z The first line is an “If” value rule—a value rule that may be either true or false, for example: “The 
recipient’s Club Level = Stellar”.

	z The second line is a “Then value”—the Content Object’s value if the above expression is true.
	z The third line is an “Else value”— the Content Object’s value if the above expression is false.

Functions

Functions are displayed in the second drop-down list. Functions give you the flexibility to convert and 
manipulate the data source value so that it fits your specific needs.  

For a detailed description of all uCreate Print functions, please refer to the uCreate Print User Guide. 

The following example rule uses the lowercase function to format the recipient’s first name in lowercase 
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Appendix C:  
XMPie Terminology
The following is a glossary of XMPie terminology that is relevant to this tutorial.  For the complete uCreate 
Print Standard glossary, please refer to the uCreate Print User Guide. 

Asset Source — in the XMPie context, this term refers to a collection of campaign assets (for example 
images, or formatted text files) and their location. In uCreate Print, you can define one asset source for a 
single campaign. The asset source can contain multiple folders and files.

Assets — in the XMPie context, this term refers to content (such as graphic files and text files) that feed 
the Content Objects in a design (as opposed to resources, which are static content). 

Business rule — see Rule. 

Campaign — a representation of a set of dynamic documents, possibly of different types, all sharing the 
same plan (logic/rules), data source and asset source. 

Content Object — Content Objects can be of various design-centric types. For example: text, graphic, etc. 
The designer uses simple point-and-click operations to tag different design objects with the relevant type 
of Content Object. (For example, the First Name Text Content Object or the Phone Model Graphic Content 
Object.)  The tagged InDesign object becomes a dynamic object: a design object that derives its content 
and/or appearance from the Content Object’s value. 

Content Object values are calculated by plan rules, using the given data source(s).  These calculations 
are performed iteratively, once for each recipient, resulting in a set of recipient-specific values for each 
Content Object. In a way, one can think of Content Objects as the intermediaries between the logic (i.e., 
Plan) and data (i.e., data source) and the design (i.e., XMPie tagged InDesign document). 

Content Samples — a set of possible values, defined by the user, for a given Content Object; different 
Content Objects can have different sets of values associated with them. There are no constraints on these 
values; except that they need to adhere to the type of Content Object with which they are associated 
(for example, the Content Samples associated with a Graphic Content Object should be a set of images). 
For example, one can define three images— "CarA", "CarB", and "CarC"—as the possible values of a 
"CarPicture" Graphic Content Object. It is then possible to flip through these Content Samples, to see 
how the different images appear in the Design, without being forced to rely on a complete data source or 
Proof Set that may not necessarily be available at the early stages of the design process. 

Content source — the source that provides values that feed the Content Objects (via rules or directly), 
which in turn change the content (or format) of the dynamic objects in your design. There are different 
types of content sources, including data sources, proof sets and content samples.

Copy Fit — adjustment of the type size to make text fit in a given amount of space. 

Data — one of the dynamic document’s basic components. In the XMPie context, the data component is 
represented by data sources and asset sources. 

Design (also known as tagged documents, dynamic document templates and uProduce documents)—
an InDesign document that includes regular and tagged design objects. Tagging is performed using the 
uCreate Print plug-in and the Dynamic Content menu and panel. 

Dynamic Document Template (also known as a Tagged Document)—see Design. 
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Expression — the rule that drives the information for an Content Object. Use the rule editor to modify the 
expression for a given Content Object. 

Graphic (Content Object) — A Content Object which is designed to dynamically change the content of 
a Graphic Frame in InDesign. The Graphic Content Object rule should return the textual file name of a 
graphic asset file. Graphic files can be .jpg, .gif, .eps, .tif, and so on depending on the desired output. 

Logic— refer to Rule.

PersonalEffect — the server-version of XMPie’s revolutionary solution for cross-media direct marketing. 
Makes personalized publishing across multiple channels simple and cost-effective. PersonalEffect consists 
of three modules: a web-based production server, uProduce, and two desktop tools, uPlan and uCreate, 
for campaign creation. 

Plan — the encoding of the rules for all Content Objects in the document or campaign is called the Plan. 
In uCreate Print the plan is encoded internally, as part of the uCreate Print document, and is not visible 
as a separate object. In PersonalEffect, the Plan can be a separate file encoded in XML, and stored in a file 
with a ".plan" extension. This enables the one plan and data source to be applied to multiple documents.

Proof Set — an XML-encoded table where columns represent Content Objects and rows represent a 
set of values - one for each Content Object - for a given recipient. Proof Sets are generated by uPlan, 
uProduce or Circle. They are typically generated for a subset of the recipients list, with possibly a few more 
filtering criteria, by executing the Plan for each such selected recipient and storing the resulting Content 
Object values in that recipient’s row. Sometimes Proof Sets may represent the whole set for which a 
specific production run is going to be executed. In such cases they may be referred to as Production Sets. 

QLingo — a scripting language developed by XMPie, to allow the use of classical conditional logic - such 
as 'if-then-else' or 'switch' constructs - in expressions that compute values for Content Objects or Variables 
in a Plan file. QLingo also supports many domain-specific constructs for formatting, process control, and 
other data manipulation functions. Together with SQL and the ability to call upon external functions, 
QLingo makes the Plan file expressions (rules) extremely powerful, yet not overly complex.   

Recipient — the person who receives an individual instance of the dynamic document. If the document 
is static, all recipients receive identical copies; if the document is dynamic, each recipient receives a 
unique document instance, which has been personalized based on this recipient’s specific data. 

Recipient List — a table whose records represent the recipients of a particular dynamic document. At 
production time, a personalized dynamic document instance is generated for each recipient (i.e., record) 
in this recipient list. 

Resources — static graphic files, which are used in the design and are fixed throughout production (as 
opposed to Assets, which change per-recipient). An example may be the company logo. 

Rule (also known as business rule) — part of the logic defined in the document or campaign’s Plan file.  
Rules are expressions that calculate Content Object values for each recipient. Rules can also be added or 
edited using uCreate Print’s Rule Editor.  In the uCreate Print context, the terms "Logic" and "Rules" are 
interchangeable. 

Static Document — a regular desktop publishing document, such as an InDesign document. 

Tagged Document — see Design. 

Text (Content Object) — A Content Object which is designed to dynamically change text in InDesign. 
The rule or expression of a Text Content Object can return any characters which can be letters, numbers 
and symbols. Of course, the font of the selected text in InDesign should support the characters (glyphs) 
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returned by the Content Object rule. Note:  This is the default Content Object type, in other words all 
Content Object, when first created are Text type.  

Text file (Content Object) — A Content Object which is designed to dynamically change the content of 
a Text Frame in InDesign. The textual name of an asset file containing text formatted in a specific style: a 
preformatted tagged-text file for use with InDesign templates. Text Files can be formated as plain text, 
Rich Text (RTF), Adobe InDesign Tagged Text, or a proprietary XMPie format called XNIP.

uChart — Part of the uDirect suite, that enables the integration of data-driven charts and graphs into the 
variable data template, ensuring chart elements fit properly within the user-defined InDesign graphic 
box.

uCreate Print — Part of the uDirect suite, that plugs into Adobe InDesign to enable the connection of the 
document design to the logic and data to create a variable data template.

uDirect — An integrated suite of XMPie software tools; uCreate Print, uImage and uChart, enabling the 
creation of variable data-driven documents using personalized images and illustrations, and data-driven 
charts and graphs. 

uImage — Part of the uDirect suite, enables the integration of personalized images into templates 
created in Photoshop or Illustrator. 

Variable  — an internal object of the Plan, which can be assigned values of expressions (QLingo, SQL, 
etc.). Variables are not visible to document design. 

Visibility (Content Object) — A Content Object which is designed to dynamically turn on/off an InDesign 
page (spread) or layer. The Visibility Content Object rule should return true/false value which acts an ON 
/ OFF switch to show or hide a layer or page spread. When used with InDesign Layers, the rule can also 
return the layer name. In this case, layers which are tagged with the rule will be turned on when the layer 
name matches the Content Object value, and off when name does not match. This is helpful when you 
want to control several layers from one Visibility Content Object.
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Appendix D:  
Database Terminology
A Flat database is one table, often stored in a Comma-Separated Values (.CSV) file, a text file (.TXT), or a 
Microsoft Excel worksheet (.XLS). 

Comma Separated Values files (.CSV) are a special type of text file:  

	z A CSV file contains one table.
	z The first line is usually called a “header” or “header row”, because it contains the names of the fields.
	z Each line in this text file is a record.
	z Each record consists of one or more fields, which are separated by commas. Sometimes the text 

between the commas is placed inside quotes, to identify that the information is to be treated as if it 
were one piece of information. This is especially useful for hidden characters, such as carriage returns.

Tab Separated Text files (.TXT) resemble CSV files:  

	z A TXT file contains one table.
	z The first line is usually called a “header” or “header row” because it contains the names of the fields.
	z Each line in this text file is a record.
	z Each record consists of one or more fields which are separated by tabs or other kind of special 

character (for example: a pipe “|” symbol)
	z Text/String fields are often placed inside quotes if there are spaces between the text.

Microsoft Excel worksheets (.XLS or .XLSX):  

	z An Excel files may contain multiple tables, unlike a one-table flat file (CSV, TXT)
	z uCreate Print can link to Excel files in Windows only, not in Mac.
	z Each worksheet is a table
	z The first line is usually called a “header” or “header row”, because it contains the names of the fields.
	z Each row is a record.
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	z Each column is a field.
	z The first column is usually the primary key field. While it is not required, it is STRONGLY suggested 

that you always include a unique or primary key field in your Excel sheets, even if you have to add it 
manually  .
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